To view our current job listings, please click on the appropiate category below. If you would like to submit a job listing to us, please click here for our job submission form.

Date Posted01/26/2021
Job TitlePsychiatric Nurse Practitioner Regular Full-Time Professional NEW YORK, NY, US
CityNew York
StateNew York
Enter a description of the Job

About the Position

Graham Windham is seeking a Psychiatric Nurse Practitioner who will be responsible for psychiatric evaluations and medication management of children and youth, including those served by our Family Foster Care program and community partners.

Duties and Responsibilities

· Conducts health assessments and psychiatric evaluations - incorporating feedback from other health care professionals, families, and staff members in other disciplines to ensure ongoing quality delivery of health services.

· Provides medication treatment and psycho- education for clients &/or families regarding medication usage and side effects.

· Refers clients for consultations and follows up as necessary.

· Participates in administrative and staff meetings as assigned.

· Exhibits customer service, decision-making and problem-solving skills.

· Effectively prioritizes and coordinates job tasks for maximum productivity.

· Ensures that medical records are kept up to date as per programmatic and regulatory standards.

· Facilitates other projects as assigned.

Please click on link below to apply:
https://workforcenow.adp.com/mascsr/default/mdf/recruitment/recruitment.html?cid=886d60c4-cb57-470a-9bab-d5266ddef922&ccId=19000101_000001&jobId=56645&source=CC3&lang=en_US

Qualifications

· Must be a licensed Psychiatric Nurse Practitioner

· Minimum of four years of direct experience with some of that experience involving treatment of children and/or adolescents

· Must possess New York State prescriptive rights

· Bilingual, Spanish speaking a plus.

Position Type

Part time/Full time Salary
Commensurate with experience

NameHeather Whyte
Company NameGraham Windham
EmailEmail hidden; Javascript is required.